Grails as deb with ivy plugin problems - fixed

When I tested Marius's grails deb package on Ubuntu some days ago, I realized there was a problem with the ivy plugin.

Today, played around with it quite a bit, and could solve the problem!

The solution is explained here And a fixed version of the plugin is available here

The bug report for the issue is here - you could vote for it so it is more likely to be fixed in the plugin's version control system and contained in the next release.